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Introduction

CDS Integration is required to synchronise the Viztopia and CDS databases to avoid double
keying relevant client details.

The details maintained in Viztopia 4 are integrated to CDS for the purpose of completing Tax
forms using Classic Tax. Therefore, the Viztopia database is the main database in which all client
names, addresses, phone numbers and so forth will be maintained.

Any time you want to have an address available in Classic Tax, add the address to the client in
Viztopia and the information will appear in CDS ready for selection in Classic Tax.

This guide is to be used when installing and activating CDS/Tax Integration on a network at a
client site or on a stand-alone workstation for demonstration purposes.

Pre-requisites
Prior to installing and activating the CDS/Tax Integration you should already have the following

installed and operational:

e Viztopia Practice Management

¢ A multi-user license of System Release
e CDS

e Classic Tax.

The required versions for the various Integration components are listed in the following table.

Software Version

System Release 7.1a or above

CDS 6.1e or above

Classic Tax 2005.1a or above
Viztopia Practice Management 4.1 or above

Visual Basic Run-time SP 5 version 6.0 or above

Configuration Overview

Summary of Workflow

Once the synchronisation components are installed, the Viztopia database becomes the source
database for all client names and address details. This means that you no longer enter client
details into Central Database (or Classic Tax).
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An Example Workflow
Adding a new client and completing a Tax return, you would do the following:

e Enter the client name, address, phone number, assignments into Viztopia.

e The information automatically synchronises to the Central Database. Within Viztopia use, the
Launch link to create the Tax return selecting the relevant addresses and phone numbers
from CDS.

If there is missing information, such as a business address, add the correct type in Viztopia
and it will appear for selection in Classic Tax.

e The only client details that need to be added into Classic Tax are items that appear on the
return that are not synchronised.

o Ifitis absolutely necessary, you can add a TxAddr address into CDS via Classic Tax which
will not appear in Viztopia. You should only do this when you have no intention of ever using
the address again, such as a previous Postal address.

What Data Synchronises?

Client Details

Individuals
First Name Middle Name Surname
Title Gender Client Code
Salutation Place of Birth Date of Birth
Entities
Pre Name (e.g. The) Main Name Client Code
Trading As Name (Alias)

Trading As Name

The Trading As name for Entities can be synchronised from Viztopia to CDS using an Alias. By
default this would be setup as Trading Name.
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Sort Views

The only sort views that synchronise from Viztopia to CDS are: Partner, Manager, Employee and
Office Index.

Viztopia Field Name CDS Field Name Comments

Responsibility Tab / Partner | Sort View / PARTNER Fixed. You cannot change.
Responsibility Tab / Sort View / MANAGER * The Viztopia field can be
Manager* called anything on the

responsibility tab and is
based on mappings
entered in the Viztopia
configuration settings.

Responsibility Tab / Sort View / EMPLOYEE * The Viztopia field can be
Employee* called anything on the
responsibility tab and is
based on mappings
entered in the Viztopia
configuration settings.

Extra / Office* Sort View / OFFICE INDEX | * The Viztopia field can be
any Extra Category / Value
and is based on the
mappings entered in the
Viztopia configuration
settings.

* the Viztopia field name can change depending on the mapping setup. However the CDS field
name CANNOT change.

Address and Numbers

Any address and number setup within Viztopia can be sychronised to CDS. However, when
considering which fields to synchronise ensure you only setup fields that are required for Classic
Tax. Any extra fields are redundant and only place unnecessary burden on the server and
databases.

The relationship between CDS and Classic Tax will dictate what data defaults in Tax. Where the
data does not default into Classic Tax, selecting from CDS is required (using [F10] key).
Therefore, all the data setup to synchronise from Viztopia to CDS will be in CDS. However not all
the data will automatically flow to Classic Tax.

For example, on the Properties tab of the Tax Return only the Phone and Fax numbers can
default automatically from CDS on creation of a new return. The remaining numbers need to be

selected using the [F10] key or clicking the selection button =l from CDs.

However, if the Phone and Fax numbers are edited or entered in Viztopia AFTER the return has
been created the numbers will not appear automatically on the Contact Numbers tab. They
need to be selected from CDS. This is the nature of CDS/Classic Tax integration; it has nothing
to do with the Viztopia to CDS synchronisation.

When you edit an address in Viztopia that is attached to a Tax return with a status of ‘Not
Lodged’, the change will appear in Classic Tax in the Front cover area and the Properties area
of the Tax return.
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Once the Tax return has been lodged, address changes in Viztopia will not appear on the Tax
return. However, the Properties tab on the tax return will update with the changes.

Fields that default from CDS to Classic Tax

Form in Tax Field name on form Viztopia Field CDS Field
Properties / Contact Numbers | Telephone (BH) Business PHONE
Properties / Contact Numbers | Facsimile Business Fax FAXBUS
Properties / Name Current Name / Name | Main Name Entity Name
Properties / Mail Current Address Postal * (based POSTAL
on mapping)
Properties / Staff Partner Partner PARTNER
Properties / Staff Manager Manager * MANAGER
(based on
mapping)
Properties / Staff Employee Employee * EMPLOYEE
(based on
mapping)

* the Viztopia field name can change depending on the mapping setup. However the CDS field
name CANNOT change.

What happens when you close a Client?

Closing a client or supplier record in Viztopia integrates the changes with CDS. Changes are
displayed on the General tab of the record. The Status will appear as Closed and the Date field
will retain the close date.

What happens when you delete a Client?

Deleting a client or supplier record in Viztopia changes the type in CDS to the “Other”. This
ensures that any Tax returns attached to the client are not lost.

Does the editing of client codes integrate to Classic Tax?

Editing any client codes in Viztopia automatically integrates to both CDS and Classic Tax.

You can choose to turn off the editing of client codes. To do this, change the configuration
settings in Viztopia to set CDSLink =1 instead of 0 (where 1 is disable editing of client code).

What is Normalisation?

In the Central Database application you are able to attach multiple values for one type of
database attribute (name, address, number). Although this has uses in Central database, it
makes it difficult when synchronising with Viztopia.

For example, there may be an address type in CDS called ‘EMAIL’. However, there is often more
than one email address. This means that, in the CDS address tab, the EMAIL address field can
have multiple values. For example; sales@myob.com and support@myob.com.
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If you choose to synchronise the email address between Viztopia and CDS you can not have
multiple values. The address type EMAIL would need to be normalised before it could be mapped
to an address in Viztopia.

The normalisation process creates extra types when it finds multiple instances of the same type.
In this case, the normalisation routine would create another address type called EMAIL1 and
support@myob.com would be attached to it.

You need to carefully consider which numbers and addresses should be normalised. Addresses
such as postal, business or residental would be normalised as they are single value type
addresses. An address such as Txaddr would not be normalised as, due to the nature of Classic
Tax there are often many instances of Txaddr attached to each client.

There is no need to synchronise and/or normalise every single number or address that exists in
CDS and Viztopia, only those that will be used in the Classic Tax product. The basic information
would be:

e Postal address

e Business address

e Homel/residential address
e Alternate address

e  Work Phone number

e Home Phone number

e Work Fax number

e Mobile Phone

e Email address.

If you have specific addresses or numbers that you use within Classic Tax, they would be the
ones selected for normalisation and then data mapping to Viztopia.

It is recommended that you decide which of the addresses or numbers from Viztopia are required
to be synchronised across to CDS. Do not choose values that you do not need in CDS.
Remember that Viztopia is now the names and contacts database, and any mail outs and
correspondence will now be sourced from Viztopia, not CDS.

Recommendations

e Synchronise only the data required in Tax. Remember, all your reporting and mail merge
functionality will now be done from within Viztopia.

¢ Normalising data: Only normalise data that will be synchronised between the Viztopia and
CDS databases. Do NOT normalise the TxAddr address. Never have a mapping with the
same hame more than once (for example, EMAIL and Email). Although they are recognised
as being different (case), it will confuse the system.

o Trading As name: In Viztopia, setup an Alias called Trading Name (if there is not already
one from the data conversion). Only enter details in the Trading Name where the trading as
name is different to the Registered name. It is important to note that when you enter a
Trading Name, Viztopia will search on the trading name and Main name. If the search criteria
meets both the Trading name and the main name then the client will appear in the search list
twice.

¢ When entering numbers, refer to the phone numbers that you will need on your Tax return.
Only the necessary phone numbers should be synchronised (see table below).

Viztopia CDS Number Comments
Number Type Type
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Business PHONE This is the Viztopia main phone number that
appears on the Detail tab under Business. It
is designed to be the main contact number
for this client during office hours.

Business Fax FAXBUS This is the Viztopia main Fax number that
appears on the Detail tab under Business
Fax. It is designed to be the main fax

number for the client during Office Hours.

Mobile MOBILE This is the Viztopia main mobile number
that appears on the Detail tab under Mobile.
It is designed to be the main Mobile number
for the client during office hours.

The following numbers are all user definable in Viztopia.

Home Home Other details: Home would represent the
clients Home phone number. For entities,
the Home phone number for the main
contact (for example, Director / Partner).

Select the responsibility level that equates to the manager, the person primarily responsible
for the client below the Partner. Normally this would be the Manager on the Responsibility
tab. This maps to the MANAGER sort view in CDS.

For the EMPLOYEE sort view, select the value on the responsibility tab that equates to the
accountant responsible for the client. If this is always the same as the manager, leave it
blank. For example, the responsibility level may be Accountant that maps to EMPLOYEE sort
view in CDS.

Setup the following address types as standards in Viztopia and link as shown in the table
(NOTE: Case is important).

This is a recommendation only, it is not a requirement. You are free to setup different
Viztopia addresses. To ensure the process is as efficient as possible it is worth referring to
the above table for what fields default into Tax.

Viztopia CDS Address Comments
Address Type Type

Postal POSTAL Would be the default address in Viztopia
and represents the default postal address
of organisations and individuals alike.

Street STREET Would be the physical address of the
business or the home address of the
individual. Setting it up as Street saves you
using TWO address types (normally
Business and Home).

Alternate ALTERNATE Where there is an alternate address for
some clients, such as an overseas address.
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Viztopia CDS Address Comments
Address Type Type

Business BUSINESS The Business address for an individual
where it is different from their street
address (for example, either their work
address or own Business address).

Email EMAIL Email address.

Delivery DELIVERY Where different from above.

If you have followed the recommendations outlined above, then chances are you have made
some changes to the Viztopia database that would need to be synchronised to CDS. For
example, changing the addresses based on above table.

It is always better to re-synchronise your data if you have the time. You are ensuring that, at this
point, everything that is in Viztopia will be synchronised back to CDS. This process does take
some time. Ensure you run it in the evening, with a minimum of 4 hours to spare before the
nightly back-up begins (time varies depending on size of database and speed of machine).

Remember to take a back-up of the CDS ledger prior to the re-synchronisation starting. You also
need to run the Viz to CDS Post routine before the re-synchronisation routine is started.

Installation Process

CDS/Tax Synchronisation installation process includes the following steps:
¢ Installing synchronisation components.

e Setting up the SRDAL (messenger) Server — SRDAL.

e Activating the integration with Viztopia.

e Synchronising the CDS (Cheetah) and the VPMSER (SQL) databases.

e Setting up scheduled tasks to turn synchronisation off and on each day to allow backups of
the Classic Tax data.

Terminology

The following table describes some of the key terms that are used throughout this installation
section.

Term Description

SRDAL The System Release Data Access Layer.

A software component that supplies a queue mechanism to
implement a store and forward messaging service.

SRDAL is installed as a system service and therefore may be
managed generically via the Service Manager available to
users within the Administrator’s group. For convenience, we
also install a control panel applet known as the “System
Release DAL”", which supports some specific management
functions.
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VizCDS Integration

A collection of components that enable data to be passed from
Viztopia to CDS. The installation loads database triggers, an
external stored procedure and an icon for launching the CDS
background process.

Datagrams

Packets of data that are sent between Viztopia and CDS and
processed by CDS.

Message Queue

The datagrams that are waiting for processing.

VPM Server

The VPM Server is the PC that includes:
SQL 2000 or MSDE

The VPMSER database

The Viztopia DAL

Practice Server

The server that has the Solution 6 Classic Tax data. This may
also be the VPM Server

Viztopia / CDS Integration 4.0
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Installation Instructions

Installation Checklist

Please ensure that you complete the installation steps in the order listed below.

Step Description Page Complete
No.

1 Check pre-requisites. 14 I:l

2 Backup the Viztopia database. 14 I:l

3 Backup CDS/Tax databases. 14 D

4 Run the workstation installation setup of System Release on the 15 I:l
SRDAL / VPM machine (where necessary).

5 Add a VizPost user to System Release and set automatic login for | 15 I:l
VizPost background operation.

6 Install SRDAL. 17 I:l

7 Install the VizCDS integration components. 21 D

8 Configure the Viztopia database. 25 I:l

9 Configure the CDS database. 26 I:l

10 Configure the Tax database. 27 D

11 Grant Permissions on Master Database (XP and Windows 2003 28 D
only).

12 Activate Synchronisation / Resynchronisation (where necessary). 29 I:l

13 Setup scheduled tasks. 30 I:l
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Check Pre-requisites

Viztopia Practice Management version — Version 4 (or
above)

To check the version of Viztopia Practice Management is Version 4.1:

1. Open Viztopia and select Help » About in the Viztopia application. Should be a minimum
of Version 4.1

If you are not running Viztopia 4.1 please contact MYOB Support. DO NOT PROCEED further
with the install.

System Release — 7.1a (or above)

To check the version of System Release:

1. Open System Release and select Help » About » Application Details. Platform
should read System Release 7.0a or above.

CDS (Central Database)

To check the version of CDS (Central Database):

1. Open Central Database (Database — Type CDS) from the ledgers list and select Help
» About. Version should read 6.0e or above.

Classic Tax

To check the version of Classic Tax:

1. Open the current year Tax ledger from the ledgers list and select Help » About.
Version should read 2005.1a or above.

Backup Viztopia (VPMSER) database

Backup and properly label the MSDE/SQL database and ensure that backup is successful. This
should be done via the MSDE Backup and Restore Utility on the MSDE server or Enterprise
Manager depending on whether MSDE or full SQL are being used.

Refer to Appendix on page 39.

Backup CDS Database

Select the CDS ledger and from the File menu, select Backup.
The ledger backup window appears.
2. Enter the drive letter of your floppy drive and click OK.
The backup process begins. Once complete, you are prompted to print disk labels.
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Solution 6 System Services -
Workstation Setup

To operate correctly, System Release requires specific files to be installed onto the local
machine’s hard drive. This is done using a workstation install.

3. Click Start » Run.
The Run window appears.

4. Inthe Open field, type x:\sol64\setup\Workstation Setup\setup.exe and press [Enter]
(where Xx: is the drive for your Solution 6 system files).

A Welcome window appears.

5. Click Yes.
The Choose System Release folder window appears.

6. If the location is not correct, click Browse and find the correct location.
7. Click Next.

The Installshield Wizard window appears and starts copying files to your workstation.
When this process has completed the Setup Complete window appears.

8. Click Finish.

The Workstation Setup program disappears and the workstation is ready to run System
Servies.

Add the VizPost User to System
Services

The VizPost user needs to be added in System Services to allow automatic login into System
Services to run the VizPost on start-up of the server.

1. Start System Services from the shortcut created on your Desktop.
The Login Gateway window appears.

=l
System Services

IJser code: I Z @
Password: I

2. Login with a user that has administrative rights.
The System Services window appears.

3. Under the Administration section on the left hand side of the window, select User
Accounts.
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A list of users will appear on the right hand side of the screen.

4. To create a new user, select File » New.
The New user properties window appears.

5. Enter the User code and Name fields.

Note: Make sure the Gateway Mandatory field is not checked. Leave the
Password field blank. The Workpath > Net path field is automatically filled by the
system if accessing on a network. For a stand-alone installation, the Workpath >
Local path field is filled by the system.

I

U TEMP %\ IZPosE
[HEE patii

6. Click OK.
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Set Automatic login to System Services
to VIZPost User

In order to prevent the login window of System Services from appearing whenever CDS
Integration is run from the SRDAL, you can run the following command from the server where the
SRDAL is installed.

1. Click Start » Run.
2. Type the following command:
<path>\sr EPSETLOG <Login Name>

Where:

<path> is your SOL64 directory where the SR.EXE file lives. Don't forget that you are
accessing this file across the network, therefore, the path will be the mapped drive.

<Login Name> is the VIZPost System Release user that you have just created.
For example: E\SOL64\SR EPSETLOG VIZPost.

Install SRDAL

The SRDAL is the System Release Data Access layer. It is recommended that the SRDAL is
installed on the MSDE/SQL machine.

It is recommended that you copy the SRDAL installation file from your CD onto your network
before installing.

1. Under your VPMInst directory on the server create a sub-directory called
CDSintegration.

2. Copy the SRDAL.exe into the CDSlIntegration directory from Viztopia 4 CD.
This file is found in the CDS Integration » Software Components directory.
3. Double-click on SRDAL.exe from the above location.
The Welcome window appears, with the Solution 6 Software Licence Agreement.
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YWelcome to the Solution B installation program. This program will
help you toinstall Solution B, Pleaze read the following license
agreement.

SOLUTION B SOFTWARE LICEMCE AGREEMENT ﬂ

Thiz iz a legal agreement between you, the Client and
Solution & Pty Ltd [4BM 29 010 280 7E1) ["'Solution &").

BY COMTIMUING %4 TH THIS INSTALLATION, ¥'OU ARE
AGREEIMG TO BE BOUMD BY THE TERMS OF THIS
AGREEMEMNT. IFY0U DO HOT AGREE TO THE TERMS
OF THIS AGREEMEMT, FROMPTLY RETURM THE
FRODUCT [including written material: and binders or other
containers] TO SOLUTION B.

=l
By installing Solution B wau are agreeing to all the terms of the

abowve agreement. [F pou agree, choosze ez, [F pou do not agree,
chooze Mo and the Setup will cloze.

< Back e Mo

4. Click Yes to accept the License Agreement.

The Choose Destination Location window appears.

| rsballs hield

s DLUTI OH 6 {E:'\...'\Sulutiun ELSRDAL Browse. .. |

Choose Destination Location E |

Setup will install System Release Data Access Layer in the
following folder.

To inztall to this folder, click Mext.

Toinstall to a different folder, click Browse and zelect another
folder.

Y'ou can chooze not ta install Spstem Releaze Data Access
Laver by clicking Cancel ta exit Setup.

Destination Folder

< Back

Cancel |

5. Choose the destination location (accept default recommended) and click Next to

continue.

The Start Copying Files window appears.

Viztopia / CDS Integration 4.0
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Start Copying Fil

Setup haz enough information to start copying the program files.
If wos want to review or change any settings, click Back. [f you
are zatisfied with the seftings, click Mest ta begin copying files.

Current Settings:

Ingtall to: C:5\Program FileghS olution BYSRDAL ;I

|matallEhield

w
»
< Back Cancel |

6. Verify that the location chosen is correct and click Next to continue.

Once the installation has finished the Install Wizard asks whether you want to start the

Control Panel Applet (CPL) for the SRDAL. Leave this option selected as you will need to
change settings in the Control Panel for the SRDAL.

Setup Complete |

Setup has finished instaling System Release Data Access Layer
an Yaur cormpter.

¥ Start control panel for System Feleaze Data fccess Laver

Click Finizh to complete Setup.

| ratall5hield

< Back I Finizh I

7. Click Finish.

The Control Panel Applet (CPL) for System Release DAL starts showing that the SRDAL
is not running.

Viztopia / CDS Integration 4.0
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System Release DAL

Status | Eunfiguratinnl Backaround F'ru:u:essl

Systemn Releaze DAL
Werzion 1.5 Build 0062

Copyright 2 2003 Pixel Components Pty Ltd

— Statuz

SR DAL Status: | Stopped

Attached workstations: Cache hit rates:

Connections to server; Read ahead:
Write through:
Open tables: .
Open databases:
QE. | Cancel Apply
8. Click OK to close the CPL.
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Install VizCDS Integration Components

The VizCDS Integration components enable data to be passed from Viztopia to CDS. The
installation loads; database triggers; an external stored procedure; and an icon for launching the
CDS background process. It is recommended that it is installed on your MSDE/SQL server.

As with the SRDAL, it is recommended that you copy the VizCDS Integration installation file from
your CD onto your network before installing.

1. Copy the VizCDS18.exe file into the CDSIntegration directory from your Viztopia 4.0
CD. This file is found in the CDS Integration » Software Components directory.

2. Double-click VizCDS18.exe in the VPMInst » CDSlIntegration directory to install the
integration components. VizCDS will update the SRDAL settings.

The Welcome window appears.

iztopia / CDS Integration 1.7 Installation

o

solution & Welcomel

Thig installation program will inztall Viztopia £ COS Integration 1.7,

Before continuing with thiz inzstallation ensure that a backup iz taken
af Yiztopia # COS Integration ledoers.

Presz the Mext button to start the ingtallation. v'ou can press the
Cancel button now if you do not want toinstall Viztopia £ COS
Inteqration 1.7 at this time.

Cancel |

Warning: Do not run VizCDS.exe across the network. The install will not work over
the network.

3. Click Next to continue.

The Visual Basic Runtime 6.0 SP5 or above required window appears. This information
window is a reminder to install Visual Runtime 6.0 SP5 before commencing with the
Viztopia/CDS Integration Installation.

If receive an error on installation you will have to install the VB 6.0 Runtime SP5. Refer to
the MS Service Packs directory on your CD.
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iztopia / CDS Integration Installation

é’ Visual Basic Runtime 6.0

solution &

SP5 or above required

Yiztapia /£ COS Integration inztallation requires Visual Bazsic Buntime
6.0 5P5 or above to be installed.

Wizual Basic Funtime installation will be required before running
ReSvnc..

4. Click OK to continue.
The Location of the Solution 6 System files window appears.

*= Yiztopia / CDS Integration 1.7 Installation

o

el Location of the Solution &
System files?

Fleaze zelect the directon where your Solution & System files are
ingtalled.

If you are on a standalone the standard location iz C:ASOLES. [F pou are
attached to a network the standard location i E:ASOLES.

If you are unzure, please check with pour Systern Adrministrator.

E:ASOLES Browsze. .. |

MHext = | Cancel |

5. If required, click Browse to open the File Location window and locate your System
Release files.

6. Click Next to continue.
The Central Database System Directory? window appears.
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9.

10. Click Next to continue. The Installation Summary window allows you verify that all
settings are correct before proceeding with the installation.

Viztopia / CDS Integration 4.0

iztopia / CDS Integration 1.7 Installation

o

solution &

Central Database
System Directory?

Pleaze zelect the directory where Central D atabaze Spstern 6.0 is
inztalled.

If pou are of a standalone the standard location is C:ASOLES. IF wou
are attached to a network the standard location iz H:ASO0LES.

If you are unzure, pleaze check with your System Adminiztrator.

H:450LE3

Cancel

¢ Back I MHext = I

If required, click Browse to open the File Location window and locate your System

Release files.
Click Next to continue.

The Queue name for Viztopia to CDS window appears. SRDAL manages a message

gueue which will need to be setup via VizCDS.

iztopia / CDS Integration 1.7 Installation

o

solufion s

Queue name for Viztopia to
CDS

Fleaze define a gueue name for the communication path between
Yiztopia and Central D atabaze Syatemn.

WHAPC2063 v megqhvizods

< Back

Cancel |

Enter the path and name of the computer containing the SQL server installation.
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/ CDS Integration 1.7 Installation

Installation Summary

solution &

System Services iz located in: 5:A50L64

Wiztopia £ COS Integration will be installed to: C:\Program Files S aolution
EAYSRDAL \wizods

WOAPC2053 v mzgghvizeds will be uzed by WizPost,

‘r'ou cah alter these settings by zelecting the Back button,

To continue with the inztallation select the Mest button.

¢ Back I Mext = I

11. Click Next to continue the installation.
The Ready to Install! window appears.

/ CDS Integration 1.7 Installation

solution e Ready to Installl

Y'ou are now ready to ingtall Viztopia / CDS Integration 1.7.

Presz the Inztall Mow button to beagin the installation or the Cancel
btk ta abort this installation,

Irnztall Mo I

12. Click Install Now to proceed with the installation or Cancel to discontinue the
installation.

The Installation Completed! window appears when the installation has been
successfully completed.

13. Click OK.
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Configure Viztopia Database

The installation of the CDS Integration components adds a number of configuration options to
Viztopia. These data mapping options are used for the CDS integration routines. You need to set
the appropriate values for each of these options. (See Configuration Overview on page 5 if you
are unsure as to what settings to enter here).

Editing the Configuration Table

To edit the CDS integration options in Viztopia Front Office:

1. Click Maintenance » Configuration.
2. Edit each of the appropriate CDS settings, entering required values based on the tables

below.

Required Configuration Table Settings

Edit each of the CDS Configuration Table settings to the values listed in the following table.

Configuration Description Mandatory | Examples
Option (for the
Yes/No Value)
CDSiIntegration Enables or disables CDS integration. A Yes 1
value of 1 enables integration, O Disables
integration.
CDSLink Set this option to 0 to enable client code Yes 0
editing in Viztopia. Set to 1 if you do NOT
want to be able to edit the client code.
CDSEmployee Discuss which Team Responsibility Type No For
the client would like integrate to CDS for the example,
Employee sort view. Employee
If the client does not want anything
integrated back to CDS for this sort view
then leave blank.
CDSlIndex Extra field — custom category / field that will | No Index Office
update the CDS sort view Office Index.
CDSManager Discuss which Team Responsibility Type No Manager
the client would like integrate to CDS for the
Manager sort view.
CDSTradingName | Discuss which Alias Type the client would No Trading
like integrated to CDS for Trading Name. Name
This Alias would most probably be already
set as Trading Name.

Viztopia / CDS Integration 4.0
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Launch Links — from Viztopia 4.1 to Classic Tax
and/or MAS

Configuration | Examples (for the Value field) Description

option

System E:\Sol64 Location of the SOL64

Services directory on the network.

Sol6MAS sr EPSTART Places the launch link for MAS

Ledger E:\\S6CLIENT\CLIENTCODE/MAS4 ledgers in Viz4 (replace drive
letter where appropriate).

Sol6Tax sr EPSTART E:\SOL63\TAX/Tax2004 — Places the launch link for Tax

Ledger cCLIENTCODE ledger in Viz4 (replace drive

letters and Tax ledger name
where appropriate).

Configure CDS Database

This configuration maps data fields between Viztopia and CDS. To do this, however,
Normalisation must be run for any Name, Number or Address that is to be mapped between
Viztopia and CDS.

From the Configuration Overview section of this document you will now have a list of addresses
or numbers required. Normalise and set the values using the following steps:

1. Login to System Services.
2. Open your database.
3. Select Utilities » Control Record.
The Control Properties window appears.

£ Control Properties x|

General Integration ] Country Specific l Options Counters l

e [T L)

2 —
Otherl: | Type
Otheiz | Type:

0K | Cancel Edt |

4. Click the Integration tab. Check that the field VPM has a tick to verify that the integration
with Viztopia is activated.
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5. Ensure that the TAX option specifies the name of the ledger directory under c:\SOL63. If
you use the ellipsis button ..., you will be able to select a valid ledger.

Warning: You must delete the Audit Trail prior to starting with the
Resynchronisation process.

6. Click Map and ensure that all normalised fields are set for client and employees (if
applies) based on decisions made from Configuration Overview.

7. Ensure you print the audit trail if required prior to deletion.
8. From the Utilities menu, select Delete audit trail.

9. If the audit trail is being maintained click Yes to confirm the deletion. If the audit trail is
not being maintained skip this step.

10. Click Map to check if the database is already normalised.

11. If the values are not normalised, click on the value in question and click the Normalise
button.

Once the normalise process has been run a green tick will appear next to the type and
you can then ‘Set’ that type to map it to a Viztopia type. For example, POSTAL in CDS
would be POSTAL in Viztopia.

Note: It is case sensitive. Ensure you type in the exact case as it appears in
Viztopia.

Configure Tax Database

It is important to ensure that the Classic Tax settings are now set to work efficiently with Viztopia
and CDS. The best results will be had with the following Control Record and User Default
settings. It is not mandatory to do these, however, it is highly recommended.

Why make these changes?

These settings will reduce the number of TxAddr addresses being created, ensuring that users
are selecting the appropriate address type from CDS (not a Txaddr). This will reduce double
entry.

Data will be updated from CDS. For example, if data were stored in Tax, the updates would not
occur, thus increasing the amount of double entry required.

Control Record Settings

Utilities / Control Record / Enter password / Defaults

e Edit names and addresses within Schedules is unchecked.

e Store New Names and addresses in CDS is checked.

e Enable Name & Address organiser is unchecked.

User Default Settings

Ensure the following settings in the default area as well as for each individual.
Maintenance / User preferences / Defaults

e Edit names and addresses within Schedules is unchecked.

e Enable Name & Address organiser is unchecked.
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Granting Additional Permissions on the
Master Database

When the Viztopia to CDS Integration is activated, the integration components invoke an
Extended Stored Procedure that does not provide execution rights by default (depending on
Operating system). The Extended Stored Procedure is created in the Master database.

You are not required to turn off the SRDAL to change the EXECUTE permissions to the
Extended Stored Procedures.

You will need to add security privileges to the user logged onto the VPM server machine. This
can be done manually if the client site has Enterprise Manager installed, or a script can be
applied when they have the MSDE Backup & Restore Utility.

For client sites using Enterprise Manager

How to add EXECUTE permissions to the Extended Stored Procedure:

Click Start » Programs » Microsoft SQL 2000 » Enterprise Manager.
Double click the Master Database.

Double click the Extended Stored Procedures.

Locate the XP_VIZ2CDS Extended Stored Procedure.

Right mouse click and select Properties.

Click the Permissions button.

Tick the EXEC option for both, guest and public users.

Click Apply, then click OK to exit.

Close SQL Enterprise Manager.

How to add EXECUTE permissions to the Viz2CDS.dlI:

© © N A~ wWDN PR

1. Using Windows Explorer, navigate to the C:\Program Files\Microsoft SQL
Server\MSSQL\Binn directory.

Highlight the Viz2CDS.dII.

Right mouse click and select Properties.

Click the Security tab.

Click the Add button.

Select the Everyone user lists.

Click Add and then OK to exit from the window.

Ensure that users are allowed to Read and Read & Execute by ticking the Allow box.
Click Apply, then click OK to exit.

© © N AW

For client sites using MSDE Backup and Restore
Utility
1. From your Consultant CD, copy the utility grant.sql to C\TEMP or equivalent.
Note: The script grant.sql is located in the CDS Integration directory.

2. Ensure that there are no blank spaces in the directory path (that is, C:\ Program Files is
not an acceptable directory path).
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Open MSDE Backup & Restore Utility and login as system administrator (sa).
Click the Set Authentication tab.

Browse to C:\Temp and select grant.sql.

Run the script.

Close MSDE Backup & Restore Utility.

N o gk w

Activate Synchronisation

Starting the VPM Background Service

After completing the Integration installation you will need to launch the VPM background process.
This process usually launches when you startup the PC.

Click Start » Settings » Control Panel.
Double click the SRDAL CPL icon.

Click Start to start the SRDAL service.
Click OK to close the CPL.

Click Start » Programs » Startup.
Select Run CDS VizPost.

R e o

é"'lul'PM background poskt process ﬂ

B ackground update process is running. .

Lazt received datagram:

Cancel

Tip: Create a shortcut on the desktop for the SRDAL for later use.

Tip: At this point, you should test the CDS Integration. First, edit the details for a
client in Viztopia. Then, check the client details in the CDS address book.

Resynchronising Databases

Resynchronisation of the databases is required if the two are at different points or extra work had
been performed on the Viztopia database when they were not integrated. Running the resynch
routine will ensure that CDS is updated with everything from Viztopia.

1. Ensure that Viz to CDS Post is running in the background, click Start » Program Files
» Solution 6 » Run CDS Viz Post.

2. Start the Resync Viztopia to CDS routine from the Start » Program Files » Solution 6
menu option.

The Resync window appears.
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X|
WP to COS rezpnchronization utility — %1.2 Build 243
Copyright € 2002, 2003 Solution & Pty Ltd

SOL Server that hosts
the "“wpmzer' databaze: I“':":a”

Updates queued to: [\\SEYRMEYmsggivizods

Currently updating: |

Cancel |

3. Click Start

This will initiate the VPM to CDS Resynchronisation Utility. This process may take
some time to run depending on your workstation resources and the volume of data.

Once the Resynchronisation process has finished you can open Viztopia and System
Services in order to check the integration.

Note: This will NOT start if the configuration settings in the Viztopia database
have not been completed correctly. You must have valid information in the
CDSintegration and the CDSLink fields.

Put SRDAL ‘to sleep’ and Setup
Scheduled Tasks

To ensure you are able to perform your nightly backups of your Classic Tax and CDS data the
SRDAL and Viz to CDS Post routines must not be actively using the data.

The following installation puts the SRDAL to sleep (so that it is not using any data files) and then
scheduled tasks will be setup to do these actions prior to the nightly backup.

SRDAL to sleep

1. From the Viztopia 4.0 CD, browse to the CDSIntegration location.
2. Copy the SendCmdA1.exe to the server location VPMINST\CDSIntegration.
3. Double click on the SendCmdA1.exe in the VPMINST\CDSIntegration directory to start
the install.
4. Accept all installation default options.
5. Check the SendCmd is working:
e Ensure ‘Run CDS VizPost’ is running (that is, background post is on the window).
e Click Start » Run and type
“C:\Program Files\Solution 6\SendCmd\SendCmd”
“S6:\\<Server>\msgq\vizcds” ZZZ
Where <Server> is the MSDE/SQL server name.
The whole command line is not case sensitive, except the last parameter “ZZZ".
This parameter is case sensitve and must be in capitals.
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MYOB
« Click OK.

The Run CDS VizPost should shut down, however, if you check the SRDAL via the
Control Panel, the status will still be running. The message queue has effectively
been put to sleep.

Run the CDS VizPost again to make sure it does wake up. The background
process interface should now be running on the desktop once again.

Scheduled Tasks Setup

Use the Windows System Scheduler to schedule tasks and ensure that you can stop and start
the message queue without any errors.

The following definitions apply to the steps listed below. You will be required to substitute these
definitions as required:

<server> - your MSDE/SQL server name.

<sr drive> - drive where network install of System Release resides.

<windows directory> - Local directory where Windows system resides.

1. From Windows Explorer, browse to C:\Temp and create a file by clicking on the right
mouse button and selecting New » Text Document.

2. Name this new text file MsgQSleep.bat and press [Enter].
The Rename window appears.

3. Click Yes, then right click on the file and select Edit.

4. In the text editor type the following:
“C:\Program Files\Solution 6\SendCmd\SendCmd.exe” S6:\\<Server>\msgq\vizcds
227
The whole command line is not case sensitive, except the last parameter “ZZZ". This
parameter is case sensitive and should be in capitals.

5. Click Save.

6. Close the text editor.

7. Create and edit another batch file called MsgQWake.bat by repeating steps 1 and 2
above.

8. In the text editor for this batch file type:
<sr-drive>:
cd sol64
c:\<windows directory>\system32\cmd.exe /c start 'SEPARATE sr.exe /f
\\<server>\s6system\sol63\DATABASE\CDS /EPCVIZPOST
s6:\\<server>\msgq\vizcds

9. Save the file and exit.

10. From the Start menu, select Settings » Control Panel » Scheduled Tasks » Add
Scheduled Task.
The Scheduled Task Wizard window appears.
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Scheduled Task Wizard

to perform.

Click Mext bo continue.

Thiz wizard helpz you schedule a tazk for windows

Y'ou gelect the program wou want Windows ta run,
and then schedule it for a convenient ime.

< Back

Cancel |

11. Click Next.

12. Click Browse and find the MsgQSleep.bat file, click Open
Scheduled Task Wizard

LClick the program you want Windows o run,
To zee more programs, click Browse.

Application I Yerzion I -
About GAIM Publishing § £.041 b

@'Accessibilit}l Wizard 5.00.2195.66...
rﬂ.ﬁ.cmbat Reader 5.1 5.1.0.200209...
'° Acrobat Reader Setup 2.02.00
st Address Book 6.00.2200.11...
E.ﬁ.dministratm
!.ﬂ'\..—lnl-\.nh ..... I =Ad ki —im mmmr 172010 LI

Browse. .. |

< Back I et

Cancel |

13. Click Next.
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Scheduled Task Wizard X

Type a name far thiz tazk. The tazk name can be
the zame name as the program name.

Perfarm thiz task:

= Daily

O Weekly

" Monthly

= Ore tirme only

" wWhen my computer starts
" when| log on

¢ Back I [Hent = Cancel |

14. Type a name for the task in the relevant field.

Type a name far thiz tazk. The tazk name can be
the zame name as the program name.

IMSQDSIEEp

Perfarm thiz task:
I
= wieekly
 Monthly
= Ore tirme only

" "wWhen my computer starts
= when| log on

¢ Back I Heut = I Cancel

15. Select Daily and click on Next to continue.
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Scheduled Task Wizard EI

Select the time and day pou wank thiz tazk to start.

Start time:

|:51 —

Perform thiz tagk:

& Ewem Day

 Weekdays

= Ewvery |1 _Ij dayz
Start date:

I 2004-07-23 = I

¢ Back I MHext = I Cancel

16. Set the Start time and select the required task frequency option along with setting the
Start date.

17. Click on Next to continue.

Scheduled Task Wizard x|

Enter the name and pazsword of a uzer. The tagk wil
run az if it were started by that uzer.

Enter the uger name: Iuser
Enter the pazsword: I’“‘"’“‘"
LCanfirm pazzword: I’“‘"’“"‘1

< Back I Hest = I Cancel

18. Enter the Windows NT/2000/2003 server user name and password to allow this task to
be scheduled and then click Next.

Note: The user name for the server is generally ‘administrator’, if you are not sure
of the correct user name refer to your Network Administrator or 3rd party
technician.

19. Confirm your selection and click on Finish.

You have now completed the task schedule to put the message queue to sleep at the
above specified time.
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20. Repeat steps 10 to 19 to schedule another task for the MsgQWake.bat file. This is to
wake up the message queue. The message queue should be scheduled to wake up after
the backup process has completed.
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Troubleshooting the Installation

Error Messages

The following is a list of error conditions you may experience trying to get the background
process up and running.

These error conditions will be displayed if you run the background process with ‘Attach to
Desktop’ enabled.

Non-licensed environment: The correct path for System Services was not entered during
the viz2cds components installation, or a valid licence for System Release is not installed.

Machine name not found: You need to run the workstation setup.

Login prompt appears: You need to create an account as per method 1 or 2 above and
ensure the System Services user properties dialog has the gateway checkbox unchecked.

Warning re printer properties not found: The default printer, or printer preference
associated with the user name in System Services points to a printer that has no Windows
printer driver installed. Correct the installation or associate a different printer, which is
installed.

User already logged in: Check the user list in System Services to identify which workstation
the user is attached to. If necessary, run an “sr EPRESET” command line to clear it.

Viztopia generates “CDS update failed”: This indicates that either SRDAL is not running
and the message queue is unavailable, or that SRDAL is running and the message queue is
full. It can also mean an incorrect path to the SRDAL was entered and it cannot be found.
Open the CPL and check that is SRDAL running. Check on the desktop that the VPM
background post process is running.

Check the CDS audit log for confirmation, the last entry should note that the background
process was started and/or list any updates since. The path to SRDAL and the message
queue being used by the database triggers should be checked by examining the
“CDSlIntegration” table in the VPM database. Reinstall Viztopia/CDS components if
necessary.

Other Troubleshooting Features

Using the CDS Audit Log

The CDS Audit Log is a handy troubleshooting guide. If the background process appears to be
having trouble errors will be reported here. It is important to have this log enabled in CDS.

To check the Computer Name, do the following:

1. From the Desktop, right-click on Network Neighbourhood.
2. Select Properties from the menu options.
The Computer Name and Domain Name are defined on the Identification tab.
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Note: For creating a domain user under a specific domain refer to your Network
Administrator.

User Not Logging Off

If the default user you have set in System Service is not logging off or you cannot get the current
user logged off, run the following command to re-set the System Services:

<path>\sr EPRESET
Where:

<path> is the mapped drive where the System Services is installed.

Network Name Not Found

If you are trying to access System Services over the network and it does open but produces an
error such as “Network Name not found”, System Services may not be a network install.

In order to carry out a network install you will need to map a drive to the machine on which you
want to install System Services. When the set up file is running, point all the directories to the
mapped drive. This will direct all the network paths automatically.

Machine Name Not Registered

If you are trying to access System Services over the network and it does open but comes up with
an error such as “Machine Name not registered”, the login account may not have the correct
access rights.

Another Folders TOC Files Already Exist

When you are trying to create a new item under an existing folder and an error “Another folders
TOC files already exists” appears and you cannot create a new item, this is due to a single file.

The problem file is “DS60P020” which is a System Services file.

You need to delete this file.

Note: Do not overwrite this file with another copy of same file from another
machine. Once the new item has been created, it will generate its own System
Services file.

Creating a SAMPLE folder in System Release

When creating a folder in System Release called SAMPLE, check the field Contains Master
Program files. By checking this box, when this sample data is accessed, System Services will
force it to go to the path that has been defined in the Folder properties window.

SRDAL Error Log

At the point of installation any error will be logged in the SRDAL Error Log located in C:\Program
Files\Solution6\SRDAL\VIZCDS or equivalent.
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Server Access

The SRDAL service will only run if a user with sufficient rights (for example, administrator rights)
is logged on.

Stopping the Background Process

When running normally, the background process may be stopped by stopping the SRDAL. This
action disables queues and hence the background process will receive an exception, log an error
to the CDS audit log, and exit recovering terminal usage counts.

If the background process has halted on an error condition, stopping SRDAL will not stop the
background process, as it will not be monitoring the message queue. In this case it is necessary
to use the NT Task Manager to kill off the process.

Stopping the VPM Background Post Process

To stop the VPM background process that runs automatically on system startup, switch to the
process and click the Cancel button.
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Appendices

Appendix A - Backing Up and Restoring
with MSDE

Backing Up Using the MSDE Backup/Restore Utility

Please contact MYOB Support if you are unsure of this process.
To backup your Viztopia database using the Backup/Restore utility, do the following:

1. Click Start » Programs » MSDE Backup and Restore Utility.
2. Login to your server using sa as the login name (with the appropriate password).

#2 Log In g|

Connection:

Server |<Yu:uur WPMServer Mame: ﬂ

[ Use NT Authentication

Authorization:

Login name: |sa

Pazsword: |

Note: Ensure that the version 5.3.5 of the utility is installed. The version level in
shown on the Login window.

3. Click the Backup History tab and locate the correct Job name.
4. Click Run Job and click the Refresh button to ensure that the backup is successful.

The Information button will show where the successful backup data is located and these
will be inside a VPMSER folder. Using the Time/Date stamp, locate and rename the
backup to Pre4upgrade.
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Databaze Mame:

Job Marme: Ibail_l,l Backup

Days ta keep backup: 10
Scheduled Start Time: 220000

Fepart Path: |C:\Backup\BackupHeport.t:-:t
Backup Path: |CZ\E~3CkUP
Check DB integrity I

ok ‘ LCancel ‘

Restoring a Database

To restore a database, do the following:

1.
2.

Click Start » Programs » MSDE Backup and Restore Utility.

Select the Server name corresponding to your computer workstation name or type it in if
it does not exist in the drop down list.

Logon by typing the user name sa with the appropriate password (no password is the
default) as shown below.

%2 Log In §|

Connection:

Server |<Yu:uur YRS erver Mames j

[ Use NT Authentication

Authorization;

Login name: |$a

Pazzword: |

Click on the Connect button to connect to the SQL server.

Click on the Restore Database tab.

IMPORTANT: Type VPMSER as the database name or select it from the drop
down.

Click on the EI icon to the right of the Restore File field and select the file that you
want. The other two path fields will be filled in automatically.

Select Overwrite Database.
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&y Backup / Restore Utility
Backup History |  Restore Database | Schedule Backup |  Schedule Aged Debt | Set Authentication |

Pleaze enter the name of the Database wou wish to restore

Database Mame:  |vpmser -

Browse ta the location of the backup file [BAK)]

Festore File: |E:\Backup\VPMSEH\F‘re4U parade.bak

Path far mdf file: |E:\F'l0gram Files“Microsaft SOL Servert5S0LAD atatwpmser. mdf

Path of log file: |E:\F'logram Files“Microsaft SOL Server\tSSOLAD atatwpmser_log |

Ok | Lancel |

8. Click OK to restore the database file.

9. Click Yes when asked the following question and wait for the restore to complete. This
can take up to a minute on large databases

10. Click on the Set Authentication tab.

Ev_l Backup f Restore Utility EHEWE
| I |

B ackup Hiztory Restore Database Schedule Backup Schedule dged Debt

Sets the authentication mode for SOL Server. Allows login authentication using either Windows or SOL Server authentication.

i Allowe wWindows Authentication only

& Allow Windows Authentication or SOL Server Authentication

[atabaze Mame: | wpMmEEr ﬂ

Path for Script | J J

Create User | Set Authentication | LCancel

11. Click the Create User button.

You should get a message indicating the user was created successfully.
12. Click OK.
13. Click Cancel to exit the Backup/Restore utility.
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Appendix B - Backup and Restore using
Full SQL Installation

Backing Up an SQL Database

1. From the Start menu, click Programs P Microsoft SQL Server »Enterprise Manager.
2. Expand the tree out until the contents of the database folder is displayed.

3. Right click VPMSER and select All Tasks.

4. Select Backup Database.

50L Server Backup - vpmser, E|

General l Options ]

[atabaze: |vpm$er ﬂ
MHame: |vpmser backup
Dezcription: |

Backup
* Databaze - complete

(" Databage - differential

~
- [l
Deztination
Backup to: ('“ {=
Add...
Remove
Contents. ..
Ovenwrite
+ Append to media
" Dwvenwrite existing media
Schedule
[ Scheduls: | J

0k | Cancel | Help |

5. If you have a file (as shown above) in the destination click Remove.
6. |If there is no file, click the Add button.
7. Select the location and type the backup database name.
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Select Backup Destination Ed |

Select the file name or backup device to uze for the
g backup operation. Backup devices can be created for files
that you use frequently.

%+ File name;

IE:"\D atabazestdatabazebackup] |

{~ Backup device:

| -

8. Click OK.
9. Select Overwrite existing media and then click OK.

SQL Server Backup - ¥PMSER Ed |

General | Optiaris I

Database: I‘-.-"F'MSEFE j
M ame: |VPMSEF| backup
Dezcription: I

Backup

¥ Database - complete
" Database - differential
£ Transaction log

£ File and filegroup:

Destination
" Tiape & Dizk
zeshdatabasebackup Add..

Backup to:

Remove

Contents...

Owenarite
" Append to media

& Ovenwrite existing media

Schedule

!l

[T Schedule: I

o

Cancel | Help

10. When prompted, click OK to complete the backup.

Restoring a Database via SQL Server

1. From the Start menu, choose Programs » Microsoft SQL Server »Enterprise

Manager.
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2. Expand the tree out until you can see under the database VPMSER.

If the VPMSER database does not exist, create it as an empty database.
Right click and select All Tasks.

Select Restore Database.

Select From device.

Click the Select Devices button.

o ok w

Restore database |

General I [ ptions I

Restore az database: I'\-’F'MSEFI j

Restore: " Database " Filegroups or files & From device

— Parameters

Devices:

Backup number: |1 Wiew Contents, ., |

¢ Festare backup et

¥ [Database - complete
" Database - differential
™ Transaction log

" File ar filegroup
" Read backup set information and add to backup history

Ok Cancel Help

7. Click Add.
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Choose Restore Devices |

Wwhen the backup iz restored, SOL Server will attempt o restore from the
devices listed below.

Backup zet: (U nknawn)
Festore fram: &+ Disk ) Tape
Device name | Add...

Edlit

Hemove

Femove Al
Media verification option

™ Only restore from media with the follawing name:

I edia name:

(1] 4 I Cancel

8. Select the file name of the database.
9. Click OK.

Choose Restore Destination E|

Select the file name or backup device to use for the restore
g operation. Backup devices can be created for files that you
Lze frequently.

{* File name:

|E:'W|:umser4.l:uak J

(" Backup device:

| =l
Ok, | Cancel |

10. Click OK.
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Restore database @

General ] Options ]

Bestore az database: |vpmser

Backup number: |1 Wiew Contents. .

{* Restore backup set
{+ Database - complete
" Database - differential
(" Transaction log

" File or filegroup

" Read backup set information and add to backup histon

Restare: (" Database " Filegroups or files + From device
Parameters
Devices: C:hwprnzerd. bak

elect Devices,

ar. | Cancel |

Help

11. Click the Options tab.

Restore database
General  Options |
[ Eject tapes (if any] after restoring each backup

= Erompt before restoring each backup

¥ Force restore over evisting database

Restore database files as: Fead from media

Logical file name
WPMSER_dat
WPMSER_log

Move to physzical file name

— Recovery completion state

C:\Program FileshMicrozoft SOL ServerMSS0...

" Leave database read-only and able to restore additional transaction logs.

¥ | eave database operational. Mo additional transaction logs can be restored.

" Leave database nonoperational but able to restare additional ransaction logs.

indo file:

C:MProgram Files\Microsoft SEL ServersMS SHLWBACKUPSUR J

u].4 Cancel |

Help

12. Select Force restore over existing database.
13. Click OK.

If your SQL databases are stored in a different location, you will need to change the Move to

physical file name to specify the correct location.
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Appendix C - Known Issues

Re-using Codes will merge the Trading Name Value

The issue affects clients (Organisation) re-using a code that had belonged to a former client, no
longer available in Viztopia.

Upon creating the client and when leaving the client’s Trading Name as an Alias, CDS will assign
the Trading Name that once belonged to the previous client to this new client, who is reusing the
former client code.

KB Article: KB013166, Tracker Job #20750

Entities without Pre-name have a space in Name
when created in CDS

When adding entities into Viztopia without a Pre-name (such as THE), the resulting entry in CDS
has a Space in front of the name. Currently there is no workaround except to enter a value in the
Pre-name if applicable.

Deleting Trading Name in VPM doesn't delete in CDS

This issue affects clients (Organisation) with a Trading Name.

When attempting to delete the client’s Trading Name (Alias type) in Viztopia, changes to CDS will
not include the deletion of the Trading Name.

KB Article: KB013167, Tracker Job #20828
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Appendix D - Installed Components

SRDAL Install

This installs and configures the SRDAL and a Control Panel applet on a machine running NT
4.0/Windows 2000 or Windows XP workstation or server. SRDAL runs as an NT service and may
be controlled from the Control Panel, or via the Services Manager.

Files Installed

The following file is installed in the SRDAL executables directory (typically \Program
Files\Solution 6\ SRDAL).

Filename Description

SRDAL.exe SRDAL executable

The following file is installed in the Windows system directory (typically \WINNT\SYSTEM32).

Filename Description

SRDAL.cpl System Release DAL Control Panel applet

Note: The Control Panel applet (CPL) has a tab to allow manipulation of the
caching parameters and message queue size. These can only be changed when
SRDAL is not running and should not be altered without advice from MYOB.

SRDAL is installed by default to start automatically at system boot using the
LocalSystem account. This can be changed using the Services Manager.

Components Registered

During the installation procedure the SRDAL executable is run with the install option. This
performs the following operations.

1. Registers SRDAL as a service with the Service Control Manager (SCM).
2. Adds the registry entries to support event logging to the Application Event log.

3. Adds the following registry keys under SYSTEM\CurrentControlSet\Services\
PhoenixServer

e Parameters
Stores the parameters set up on the Configuration tab of the Control Panel applet.
These include: ReadCache, WriteCache, MaxQueue and SQLServer.

e Process
Stores the parameters set up on The Background Process tab of the Control
Panel applet. These include: CmdLine, Username, Domain, Password, CurrentDir
and Debug.

e Status
Stores the information displayed by the Control Panel applet. This information is
dynamically updated whenever the applet is active.
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Viztopia/CDS Integration Components

This installation sets up the components required for VPM to CDS integration. It has been
designed to support a single or dual server configuration. In this configuration the Integration
components and SRDAL are installed on the same machine that hosts the VPM database.

CDS 6.0b (or above) is also installed on this server or alternatively on another server which
already has an existing System Release installation. It is connected with full access rights via a
LAN to the server on which the integration components are installed.

This installation uses the System Release 6.1 runtime to support the messaging functions used
by the CDS 6.0b (or above) Viztopia background posting process (EPCVizPost).

The background CDS posting process (EPCVizPost) writes messages to the CDS audit log (if
enabled) when it starts, stops, errors or updates any data.

The installation requires that you:

¢ identify the location of the existing System Release installation.
¢ identify the folder location of CDS therein.
e enter a valid SRDAL QueuePath.

The installation process makes an assumption that the user executing the install is a member of
the administrator’s group and is also an SQL administrator with full access to the VPM database.
If not, the install will fail.

Note: Prior to running this install make sure that:
SRDAL has been installed, is stopped, and that the CPL is closed.
Viztopia has been installed and is not being accessed by any users.

CDS 6.0b(or above) has been installed.

Files Installed

The following files are installed in the vizeds directory below the directory in which SRDAL was
previously installed (typically C:\Program Files\Solution 6\ SRDAL).

Filename Description

Resync.exe A VB 6.0 utility to synchronise the CDS database to VPM.
s6bmpedt.dll System Release image editor.

s6db.dll 16-bit Cheetah File System (CFS) support.

s6prof.dll Memory profile handler.

s6tool.dll System Release 16-bit utility library.

s6ute.dll System Release command line support utilities.

Sr.exe System Release 6.1c (or above).

Uninstall.bat Command file to execute UninstallViz2CDS.sq|l.
UninstallViz2CDS.sql Transact-SQL script to remove triggers etc. from VPM
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UninstallViz2CDS32.sq]

database (vpmser).

Viz2CDS.sql

Transact-SQL script to add triggers etc. to VPM database.

mdac_typ.exe

MDAC 2.1 support required only by Resync.exe.

VBRun60sp5.exe

VB 6.0 runtime support required only by Resync.exe.

The following file is installed in the SQL executables directory (typically C:\Program
Files\Microsoft SQL Server\MSSQL\Binn).

Filename Description

Viz2CDS.dll SQL extended stored procedure used by Viz2CDS triggers.

The following file is installed in the 16-bit system directory (typically C:\WINNT\SYSTEM)

Filename Description

MFCOLEUI.DLL Required by s6db.dll.

Components Registered

The registry entries under SYSTEM\CurrentControlSet\Services\PhoenixServer\Process are

updated.

The installation also adds a single row table (CDSIntegration) to the VPM database, containing
this QueuePath for messaging, which is used by the Viz2CDS triggers.
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